Errors on exported model (Revit to glFT)

Post Reply
marcondes
Posts: 1
Joined: Mon Sep 23, 2019 2:39 pm

Errors on exported model (Revit to glFT)

Post by marcondes » Mon Sep 23, 2019 4:05 pm

Hello guys,

I'm testing the simlab extension to convert revit(2020) models to GLFT.
I'm using the sample model rac_basic_sample_project.rvt.

Viewing the model looks kinda ok, my main issue is that transparent materials are opaque.
(I can't see trough windows.)

Probably that's my problem, not a problem caused by the simlab exporter but a problem with my renderer.

The other problem is obviously a problem with the simlab exporter:
82987 format validation errors.

I know that they are validation errors and that this errors are not critical for displaying the model...
But It's ugly, and there is a lot of them...


So, basically my questions are, why so many errors?
Is there a plan for correcting this validation errors?


I hope this will not be a problem, because I've found this extension to be super useful and I would like to propose my company to buy it. But I need some sort of explanation about this because it worries me.

I need to trust the exporter to use it.

Bellow follows the report with one "unique" error for each kind, for easy review.

Validation report
Format: glTF 2.0
Generator: SimLab GLTF
Stats:
0 animations
64 materials
727 meshes
3671 nodes
727 primitives
19 textures
Extensions: None
Report generated by KhronosGroup/glTF-Validator 2.0.0-dev.2.7.

Error Message Pointer
ACCESSOR_MAX_MISMATCH Declared maximum value for this component (1.1754943508222875e-38) does not match actual maximum (-1.80446195602417). /accessors/25/max/0
...
...
...
ACCESSOR_NON_UNIT 40 accessor elements not of unit length: 0. [AGGREGATED] /accessors/6
...
...
...
Info Message Pointer
MESH_PRIMITIVE_UNUSED_TEXCOORD Material does not use texture coordinates sets with indices (0). /meshes/0/primitives/0/material
...
...
...
/meshes/725/primitives/0/material
NODE_EMPTY Empty node encountered. /nodes/1
...
...
...
UNUSED_OBJECT This object may be unused. /samplers/0
...
...
...
IMAGE_NPOT_DIMENSIONS Image has non-power-of-two dimensions: 811x502. /images/3

User avatar
SimLab
Posts: 3010
Joined: Mon Jan 04, 2010 8:09 am

Re: Errors on exported model (Revit to glFT)

Post by SimLab » Wed Sep 25, 2019 3:51 pm

The plugin was just updated to address this issue.

Please download latest version from the following link

Result is shown below
gltf-from-revit.png

Post Reply