PDF Doesn't Open on Perspective View

Discuss Simlab 3D Plugins developed for McNeel's Rhino 3D
Takenforgranted
Posts: 76
Joined: Sun Apr 11, 2010 12:19 pm

PDF Doesn't Open on Perspective View

Postby Takenforgranted » Mon Jun 26, 2017 5:51 pm

Since installing the PDF plugin on my Windows 10 workstation, any 3D PDFs I create with it don't open on the Perspective view as set up in my Rhino viewport (or any of the ortho views if I put one of those at the top of the list either). Instead, I get what looks like a blank, coloured page. I think (but I can't be sure) that it is actually a very close-up view of one of the parts in the model.

If I open the PDF in Acrobat Reader and select "Perspective" or "Starting View" from the left-hand menu, the model sorts itself out and I can then view it as usual.

Is there a fix for this? It's not great when the first thing I tell clients the first thing they have to do is set the view correctly! I never had this problem on my previous (W7) machine.

SimLab
Posts: 2640
Joined: Mon Jan 04, 2010 8:09 am

Re: PDF Doesn't Open on Perspective View

Postby SimLab » Wed Jul 05, 2017 9:03 am

We will look in this soon.

There should be no difference between Windows 7 and 10 in this regard, but we will check with windows 10 and let you know.

Takenforgranted
Posts: 76
Joined: Sun Apr 11, 2010 12:19 pm

Re: PDF Doesn't Open on Perspective View

Postby Takenforgranted » Tue Dec 12, 2017 4:09 pm

Do you have any update on this? It's still happening and it's annoying.

I've just opened up an old 3D PDF that I made with the Rhino plugin/ Windows 7 some years ago and that opens straight to the correct perspective viewpoint on my Windows 10 PC, so I think the change of behaviour has been caused either by the Simlab plugin or Windows 10 and it is part of the way the file is saved rather than anything to do with the way Adobe Reader opens the file.

SimLab
Posts: 2640
Joined: Mon Jan 04, 2010 8:09 am

Re: PDF Doesn't Open on Perspective View

Postby SimLab » Tue Dec 12, 2017 5:19 pm

Can you share us a simple rhino file, with the generated 3D PDF file.

Takenforgranted
Posts: 76
Joined: Sun Apr 11, 2010 12:19 pm

Re: PDF Doesn't Open on Perspective View

Postby Takenforgranted » Tue Dec 12, 2017 7:58 pm

Files attached. Before saving the PDF out, the Rhino Perspective viewport was set to 'Perspective' in the right-click menu. It is the default Perspective viewpoint. To frame the ortho views, I Select All, then ZoomSelected for all three. The only tweak I make when saving out the PDF is to bump 'Perspective' up to the top of the list in the plugin dialogue box, and put 'Top' second.

I notice the thumbnail for the PDF is also blank.

I'm not sure what view the Simlab plugin is saving as the starting view, but it's none of the Rhino views. If you select 'Perspective' in the left hand view menu, everything swings into view.
Attachments
PDF TEMP.zip
(529.38 KiB) Downloaded 7 times

SimLab
Posts: 2640
Joined: Mon Jan 04, 2010 8:09 am

Re: PDF Doesn't Open on Perspective View

Postby SimLab » Thu Dec 14, 2017 5:48 pm

When the plugin exports the views they are ordered alphabetically

move the perspective camera to be the first one, as shown in the attached image

cameras.png
cameras.png (6.77 KiB) Viewed 209 times


I attached the result PDF file below

example1.pdf
(1.02 MiB) Downloaded 10 times

Takenforgranted
Posts: 76
Joined: Sun Apr 11, 2010 12:19 pm

Re: PDF Doesn't Open on Perspective View

Postby Takenforgranted » Thu Dec 14, 2017 6:45 pm

Yes- that's what I did. Hence the comment I made "The only tweak I make when saving out the PDF is to bump 'Perspective' up to the top of the list in the plugin dialogue box, and put 'Top' second."

The PDF I attached is the result. Nothing I have tried in the setting panel will change this behaviour.

Any suggestions as to what is causing this? Is the PC you used to save yours running Windows 10?

SimLab
Posts: 2640
Joined: Mon Jan 04, 2010 8:09 am

Re: PDF Doesn't Open on Perspective View

Postby SimLab » Fri Dec 15, 2017 11:56 pm

Yes, I tested with Windows 10.

Please try to uninstall the plugin
Clean Registry
from Windows -> Run
type regedit

Delete the folder

HKEY_LOCAL_MACHINE\SOFTWARE\SimLab\3DPDFfromRhino

download and install latest version from our side.

This may need activation

Please let me know if this fixes the issue for you.


Return to “Rhino 3D Plugins”

Who is online

Users browsing this forum: No registered users and 1 guest