Texture Quality - Object Edges are not smooth (Round appears as octagon)

Discuss Simlab Composer released by Simlab Soft
User avatar
Tessla
Posts: 1779
Joined: Sun Oct 05, 2014 12:15 pm

Re: Texture Quality - Object Edges are not smooth (Round appears as octagon)

Post by Tessla » Sun Feb 17, 2019 12:40 am

Perhaps reinstall the software.. That might bring it back. But the Tessellation option is not available for all objects. And I do not think you can go back to edit your settings after import. But we should be able to.. Perhaps a feature request..

Tesselaar.

BurrMan
Posts: 156
Joined: Tue Jun 15, 2010 12:38 am

Re: Texture Quality - Object Edges are not smooth (Round appears as octagon)

Post by BurrMan » Sun Feb 17, 2019 1:52 am

Resetting the dialogue...
reset dialogue.jpg

User avatar
Tessla
Posts: 1779
Joined: Sun Oct 05, 2014 12:15 pm

Re: Texture Quality - Object Edges are not smooth (Round appears as octagon)

Post by Tessla » Sun Feb 17, 2019 1:55 am

Thats good to know.. :D

T..

BurrMan
Posts: 156
Joined: Tue Jun 15, 2010 12:38 am

Re: Texture Quality - Object Edges are not smooth (Round appears as octagon)

Post by BurrMan » Sun Feb 17, 2019 3:03 am

Tessla wrote:
Sun Feb 17, 2019 12:40 am
But the Tessellation option is not available for all objects. And I do not think you can go back to edit your settings after import. But we should be able to.. Perhaps a feature request..

Tesselaar.
Hey Tesselaar,
Not available for all objects? Well, it is available for NURBS formats and object, that need to be tessellated. It wont be available for "Obj" and others, those have already been diced up...

"Re-tessellation" is more of a modeling operation, and Simlab is not really designed to be a modeler.

But they have created "Dynamic links". A means to re-access the tessellation of An MCAD file might be handy! Although, they have a means to bring the model in again, in another import, and assign it to any work you have already done with regard to animation, etc.... So, importing it again is pretty fast.,..

User avatar
Tessla
Posts: 1779
Joined: Sun Oct 05, 2014 12:15 pm

Re: Texture Quality - Object Edges are not smooth (Round appears as octagon)

Post by Tessla » Sun Feb 17, 2019 11:20 am

Yes, that all makes sense..

T...

Kush Desai
Posts: 28
Joined: Thu May 04, 2017 7:02 pm
Location: India
Contact:

Re: Texture Quality - Object Edges are not smooth (Round appears as octagon)

Post by Kush Desai » Sun Feb 17, 2019 4:25 pm

Thank you so much for your kind help... but somehow this option is not available in my version. which version you are on it ?
Import.jpg
Import settings

BurrMan
Posts: 156
Joined: Tue Jun 15, 2010 12:38 am

Re: Texture Quality - Object Edges are not smooth (Round appears as octagon)

Post by BurrMan » Sun Feb 17, 2019 9:50 pm

Hi Kush,
I am on Ver. 9

But I don't think its a version thing. The tessellation setting is there for NURBS imports. If you are importing a mesh, then there will be no tessellation option.

I guess I could be wrong on that.

So, try a STEP or SAT or IGES model....

Jakob Normand
Posts: 14
Joined: Tue Nov 28, 2017 4:24 pm

Re: Texture Quality - Object Edges are not smooth (Round appears as octagon)

Post by Jakob Normand » Sun Feb 17, 2019 11:36 pm

BurrMan wrote:
Sun Feb 17, 2019 9:50 pm
Hi Kush,
I am on Ver. 9

But I don't think its a version thing. The tessellation setting is there for NURBS imports. If you are importing a mesh, then there will be no tessellation option.

I guess I could be wrong on that.

So, try a STEP or SAT or IGES model....
Hi All
Simlab Composer is not alone in this - the exact same thing goes for Keyshot, and it all has to do with what Siemens let's outside parties read from the proprietary Solid Edge format. In other words: Siemens only makes the the render mesh from the file available, not the raw NURBS data. So you will have to crank up your settings in Solid Edge. The reason you are seeing a more smooth edge inside Solid Edge, is that they are probably applying their own welding to the vertexes, making them appear smoother than they really are. I don't have access to Solid Edge here, but according to some of the bigger brains in the Keyshot forum, the steps to take in Solid Edge are:
1. Open the part model by itself (not the containing assembly)
2. Adjust the Arc smoothness setting to an acceptable value (but only as high as absolutely necessary)
3. Save the part model
4. Repeat steps 1 through 3 for the ALL components that need refinement
5. Import the Assembly
In addition, the "auto-sharpen" under the SolidEdge options "view" tab should be set to high.
I hope this helps :)
-Jakob

PS It's the same for the Rhino format - probably others too.

User avatar
Pocc
Posts: 60
Joined: Sun Jul 30, 2017 5:32 pm
Location: UK
Contact:

Re: Texture Quality - Object Edges are not smooth (Round appears as octagon)

Post by Pocc » Mon Feb 18, 2019 12:18 pm

I too don't have access to Solidedge anymore, but in Solidworks there is a slider for 'curve quality' which does the same thing as Burrman is describing for Solidedge. There is a 'per part' setting - which dramatically increases the file size and a 'graphics' setting which affects how the part is viewed on screen whilst rotating etc in 3D space.

I hadn't seen the resolation slider before as it's not present on solidworks/solidedge imports - but it is there if I import an IGES file and it does make a massive difference - good spot Burrman!

Post Reply